LucasForums (
-   Help! (
-   -   Grim Fandango in Vista (64bit) (

Silvek 01-21-2008 04:20 AM

Grim Fandango in Vista (64bit)
So, it was that time again...time to dig up Grim Fandango and once again relive the epic tale of crime and corruption in the land of the dead...

However, naive as I was, I didn't really spend much thought to the fact that the game is 10(!) years old and that I'm running an OS that has an incredible hard time running older software. So naturally, nothing worked.

But only after a few minutes of browsing around here, I found the excellent setup/installer by bgbennyboy which seemed to be all that I needed. And true, it installed the game alright but when I start the launcher, it tells me that I should install the patch and when I click yes, it tries to download the patch from Lucasarts...and that's it...then the launcher hangs and becomes non-responsive.

I've tried to manually apply the patch, but I only get a error message saying that the game is already a later version than the patch (which of course it isn't).

So, I could use some help here...
Has anyone got the game to work on a 64-bit Vista? Has anyone encountered this issue before?

Any help would be appreciated.

Thrik 01-21-2008 04:43 AM

If it's giving you that message it's possible it did manage to patch after all. Have you tried just running the game and seeing if it works or not?

The patch doesn't really address any XP/Vista issues as it came out not long after the game itself. It just fixes some bugs during the game and adds text to cutscenes (option).

Silvek 01-21-2008 05:18 AM

No, I get the same message if I try to install the patch directly after installing the game (via the setup/launcher). It could be that the launcher software modifies the registry to think that you have installed the patch, I don't know exactly what it does.

And it does not download the patch, the progress indicator of the launcher never moves before the program "hangs".

And every time I start the launcher, it prompts me to install the patch.

James Isaac 01-21-2008 06:15 AM

What happens when you try running the game without bgbennyboy's launcher? I don't think the patch is completely necessary to play the game.

Thrik 01-21-2008 07:14 AM

You should be able to launch Grim Fandango directly if you go to your Grim Fandango directory (most likely C:\Program Files (x86)\LucasArts\Grim\) and open grimfandango.exe.

I'm not sure what happened with Benny's launcher. Perhaps he didn't create a countermeasure for when LucasArts' patch FTP is down for whatever reason. Whatever the case, he'll see this thread before long and be willing to look into it I'm sure.

But yes, the patch itself shouldn't really affect your ability to launch the game. By accessing the .exe directly you should be able to get it going. :)

bgbennyboy 01-21-2008 01:47 PM

There are only (to my knowledge) two versions of Grim. The original and the reissued one that comes with the patch pre-installed.

When it loads the launcher checks GrimFandango.exe and tries to read its version. When patched, the Grim version is - the original unpatched Grim has no version string at all. So if the version is or less, or doesn't exist, then the launcher decides that Grim is unpatched and offers to download and apply the patch.

Sometimes it can be a short while before you see the progress bar move if your internet connection is slow or the LEC site is slow to respond. After a while, if it cant contact the LEC site then it will produce an error message.

Anyway - how to fix all this? The simplest thing would be to look at GrimFandango.exe yourself. Right click it > properties > details tab. The product version string should be 1.01 and the file version If those aren't there on the details tab then it is the unpatched version.
[Edit] Also, see if the file Patch05.bin is in your Grim folder.

Silvek 01-21-2008 01:59 PM

I gave it a try, only thing I got was an error message:
Grim Fandango could not find files!
Please make sure that the game is properly installed and that the CD is in your drive.
Also, I'm sure that there isn't anything wrong with the launcher/installer, it seems solid in everything else...

So, to sum up. I can install the game using the launcher/installer, but when I try and run it, I get the error message above and when I try to patch it (using the launcher), the program hangs...

I checked the properties of GrimFandango.exe and both File vesion and Product version are blank.
Also, I don't have any Patch05.bin in the GF folder.

Silvek 01-21-2008 02:58 PM


Originally Posted by bgbennyboy
Sometimes it can be a short while before you see the progress bar move if your internet connection is slow or the LEC site is slow to respond. After a while, if it cant contact the LEC site then it will produce an error message.

You were right, after leaving it running for a while (while ignoring Vista's claim that it was "Not responding"), it produced an error message:
File not found patches/pc/GFupd101.exe
I tried to download it manually from Lucasarts and it worked fine...
It seems like Vista might not allow the launcher to get the patch (which would not surprise me at all, considering how much Vista blocks).

Yep, it was the firewall that blocked the ftp connection from the Launcher...figures...
Anyway, even with that out of the way, the problem remains, as soon as the launcher has downloaded the patch, I get the same errormessage:

Longcat 01-21-2008 06:40 PM

if you really want to patch it so bad, I suggest you try my homemade modified version ... included is the patched files, and multithreadprocessing is already disabled in the exe, so you shouldn't have any problems with that... plus some minor tweaks, I've run this just fine under both Vista 32 and 64.
Just copy the files to your install directory (usually \Program Files\LucasArts\Grim\) and run grimfandango.exe.

Grimdata Homebrew

EDIT; oh, and the goodtimes.reg key enables debuging mode, but I guess you don't want to mess around with that, although it has sometimes helped to run it in this mode if all else failes.

Silvek 01-22-2008 03:28 AM

I wouldn't say that I need to patch it bad, I mostly want it to run...

As it is now, I can't even get the game to start by using the Launcher...

Thanks for the file, I'll give it a try later when I'm back from work.

Thrik 01-22-2008 05:20 AM

Have you tried just uninstalling it and then starting over? It sounds like somehow things have gotten pretty messed up. Uninstalling and then maybe deleting the registry keys if they're not removed seems like the best idea.

Silvek 01-22-2008 07:02 AM

I plan to do that later today...

First uninstall the game completely, removing the directory and registry settings, then reinstalling the game using bgbennyboy's launcher.

Then I will start the game, if that's not working, then I'll install the patch.

If patching fails, I'll try Jona's homemade modified version and then try to run the game again...

If that fails...well, then I'll probably come back here to rant a bit more ;)

Just one thing, where are all the regestry settings located? I want to make sure I get them all...

Longcat 01-22-2008 08:41 AM

you could search for LucasArts in the registry... but I think most of the keys are deleted when you uinstall the game, except when you've for example registered the good_times key.

Silvek 01-22-2008 01:12 PM

Ok, here we go...

Uninstall Grim Fandango and delete the directory..........Check
Verify that the registry is clear......Check, no hits on "Lucasarts" or "Fandango"

Install the game using the launcher.....Check
Start the game.....Failed, error message:
Grim Fandango could not find files!
Please make sure that the game is properly installed and that the CD is in your drive.
Install patch via laucher......Failed, error message:
Grim Fandango is already up to date.
The game data is more recent than this update.
Unpacked Jona's homemade modified version.......Success!

The game starts and runs beautifully...

So I can't even start the game before I've patched it, and I can't patch the game using the normal updater... :confused:

I can't even begin to come up with an explanation for this...

Thrik 01-22-2008 01:18 PM

Very weird.

It does sound slightly possible you have a version of the game that's a bit different to the two versions Benny mentioned earlier. Perhaps you could provide more details about it (language, date on box, etc).

Silvek 01-22-2008 02:02 PM

Sure, but I don't think that there's anything special about my version...
I haven't had any problems since I upgraded my system to new hardware and Vista.

I bought it in Sweden so it's ingame language is in English, The language on the back of the box is in Swedish, Danish, Norweigan and Finnish.

Date on box...ehhm? Where is the date? I can't find it...

Longcat 01-22-2008 02:51 PM

Well, not to not be nice to bg, I love your work man;), but I've also had problems with the installer before... I'm actually working on a DVD-installer for grim, wich will make your game patched, multithreadingproof, NO CD-compatible and so on...
glad to hear my patch worked though

Thrik 01-22-2008 03:24 PM

If anyone can get Grim Fandango to work with hardware acceleration and anti-aliasing with GeForce 8s (And beyond?) I'll give you $40. ;)

Longcat 01-22-2008 03:27 PM

Haha, I think you'll have to wait for the ScummVM team to get their behinds in gear with Residual for that one. Didn't you find a way to rollback the Nvidia drivers on newer cards incidently? Something about the older driverversions being burried in the firmware?

Thrik 01-22-2008 04:18 PM

Unfortunately either Vista or the Vista drivers don't give you those buried modes anymore. :(

Grim Fandango just seems to have generally very bad corruption when hardware acceleration is used with a GeForce 8. Zaarin (known here as s-island) gets the same with his GeForce 8 on Windows XP. Using older drivers isn't really an option with such new cards either.

I really hope Residual helps, but the 'to do' list has remained pretty static for an extremely long time. Even the walk/run animations for Manny aren't implemented properly yet, and it also freezes up if I force anti-aliasing via the NVIDIA control panel which is a bit of a pain.

O Grim Fandango, I love you so.

Longcat 01-22-2008 04:24 PM

hmmm, yeah, Residual has been extremely static lately... too bad about the drivers, I was thinking of putting some sort of automated rollbacksequence into my installer... I'm lucky though, runs just fine on my ATi Raedon.
I guess the lesson to be had is that Vista is evil and should be banished for all time.

Silvek 01-23-2008 05:03 PM

Ok, I've experimented around a bit, and here's what I found out.

First up, I wanted to make sure that there wasn't anything wrong with my discs, so I installed the game on my laptop which runs XP. Everything worked fine, I used the original game installer and downloaded the patch, which applied without any issues and the game started perfectly.

Then I used the launcher/installer from bgbennyboy, installed the game without any problems but when I was going to install the patch, I got the same error as on my other computer.
Grim Fandango is already up to date.
The game data is more recent than this update.
The game still starts without a problem though.

So, if I use the launcher/installer, I cannot apply the patch normally, neither on Vista nor on XP.

My guess was that it had something to do with the registry, so I did a little trial and error on the entries there, and found the problem. There is a dword named "MAGIC" and it was set to 00016382 for me. When I deleted this parameter, the patch would install without a problem, both on Vista and XP.
After the patch was installed the "MAGIC" parameter appeared again, with a different value (00092774).

And as for my other problems, I don't know if I should blame it on Vista or 64-bit OS or both...

So, to sum up!
To get Grim Fandango to run on my 64-bit Vista system I had to:
  • Install the game using bgbennyboy's launcher
  • Remove the "MAGIC" dword from the registry
  • Install the patch (using the launcher or manually)
  • Launch the game :D

One more thing, Vista has a funny way of putting stuff in the registry, it doesn't put the Lucasarts stuff under [HKEY_LOCAL_MACHINE\SOFTWARE\, but instead under [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\.
More Vista magic :lol:

Jona, your DVD installer sounds interesting, I look forward to trying it :D

Longcat 01-23-2008 07:14 PM

that's nice, I wasn't really sure if anyone would be interested in something like that. I'm so tired of having all those games on multiple discs, so I'm actually working on a few others as well, trying to make them single disc and at least XP compatible.
As for Grim Fandango, I'm writing the installer in NSIS, and a new setup menu in something else I guess, only done with the graphics for that one.

bgbennyboy 01-26-2008 03:02 PM

Thank you Silvek for checking that. You're quite right that the MAGIC reg key shouldn't be there - that error is entirely my fault. I've now updated the setup so it doesn't create that key.
Also the reason your registry goes in the Wow6432Node is because you're using 64 bit windows - Vista64 maintains a separate registry tree for old 32 bit apps like grim.

Jona: If you've had/are having problems with the installer I'd appreciate it if you told me. Unless people like Silvek tell me about these things I cant fix them :) Also feel free to use/adapt my installer source if you're making a dvd installer - all you'd need to do is remove the cd2 check and it'd copy all files from one source.

Longcat 01-26-2008 10:29 PM

Thank you for that bgbennyboy:) Hadn't actually thought of that, I'll have a look at the source code. As for problems I've had, they occured a long time ago, so unfortunately I can't remember any spesifics, but I'm pretty sure they were of the same nature as Silveks. That be said, I used your installer a few months back and it worked fine, so I don't think you have to concern yourself with that.

I'll post a few updates on the installer as it progresses, and propably nag you to death for beta on your source:P

Sven_Q45 01-29-2008 05:36 PM

It runs on my XP. :) But i have the XP/Vista version. (Version 2.0) This is avaible in Germany and UK. And other countries? I donīt know.
Thatīs the third time i have GF. :D The quality of the CDs are bad. :rolleyes:

Longcat 01-30-2008 04:02 PM

verson 2.0? of Grim Fandango? never heard of that release, my boy. where'd you get it from?

Thrik 01-31-2008 05:33 AM

Yeah, I'm somewhat surprised you have an XP/Vista version. Is it a new re-release?

I have a copy of the 2002 re-release (or somewhere around then) that comes in a DVD case, but it still has 95/98 on it and makes no mention of XP, although it did work on XP. It has trouble with Vista, though.

I'll go shop scouring if it's been re-released in the UK.

Sven_Q45 01-31-2008 03:53 PM

In Germany this Re-Releases released in March, 22.07. (Monkey Island 3, Sam & Max, Full Throttle and Grim Fandango)


Gerade mal installiert. Und....Sam & Max läuft unter Vista.
I translate it in 4 words:
It works under Vista. ;)

Btw, yes 2002 is right. :)

And the background music in Sam and Max is now like Soround Sound. :eek: lol

Longcat 01-31-2008 05:16 PM

wow.. that just renders all my efforts... completly pointless:P any ideas what changes have been made? and are the releases in english? and also, what kind of graphics card do you use? does it support nVidia now? would be cool if you could post some specs(if you have any that is).
edit; and is the polygonresolutian any higher?

Thrik 01-31-2008 05:53 PM

Looks like I'm going to the game shop next week. ;

I'm about due for a replay of Grim Fandango so if it is distinct from the earlier versions beyond the installation I'll be sure to let you know.

Longcat 01-31-2008 07:11 PM

I've had a look around the net, and it looks like these releases are only available in german, but please give us some feedback chris:)

edit; chris? wtf, I HAVE to stop posting when I'm stoned, I mean Thrik of course...

Sven_Q45 02-01-2008 04:39 PM

I have an NVidia 6600LE, 512 MB Ram, 120GB and Pentium 4 with 2,41 GHZ.
Actually itīs very simple. There are all folders and files from the Dos and Windows versions (Sam and Max and Full Throttle). And there is a file with an icon. All you have to do is to click on this item and you can play it on XP and Vista. GF and CMI do not have extra files, but it works on XP and Vista. Btw the “old” ones works on XP, too. ;)
And there are explanations how you can start it on Windows 9x/ME, 2000/XP and Vista. (Sam and Max, Full Throttle) The patch of GF is avaible on the CD.

Full Throttle and Sam and Max:
Both version 2.0.

Grim Fandango and CMI:
Both version 1.01

Both Sam and Max and Full Throttle have a graphic-filter. (Btw you can choose this in ScummVm, too) Only in Sam and Max the background music is better, then the old one. Technical all games are the same.

System requirements:
100% DirectX PC, Pentium with 133MHz or faster, 64 MB Ram or more, 4 X CD-Rom, PCI or AGP graphic card, 16 Bit sound card, full installation 1,2 MB (?) (I think thatīs a mistake. They mean 1,2 GB), Windows XP

Grim Fandango:
100% DirectX PC, Pentium with 133MHz or faster, 64 MB Ram or more, 4 X CD-Rom, PCI or AGP graphic card, 16 Bit sound card, optional: 3D graphic (4 MB PCI or AGP 3D acceleration), installation 30 MB and full installation 1300 MB, Windows XP

Full Throttle:
100% DirectX PC, Windows XP, Pentium with 133 (!) MHz or faster, 64 (!) MB Ram or more, PCI or AGP graphic card, 4X CD-Rom, 16 Bit sound card

Sam and Max:
100% DirectX PC, Windows XP, Pentium with 133 (!) MHz or faster, 64 (!) MB Ram or more, PCI or AGP graphic card, 4X CD-Rom, 16 Bit sound card

Btw I have the first (text) adventure from 1976 and it works on XP, without any trouble. 8) I think thatīs luck. :D Each PC is differently.

s-island 02-01-2008 05:14 PM


Only in Sam and Max the background music is better, then the old one.
It's the MIDI music from the original release played through DirectMusic's software synth.

Thrik 02-01-2008 05:19 PM

Ah. Pretty simple fix in the case of Grim Fandango, then. I'm guessing nothing's been done to address the issues that arise with hardware acceleration on new NVIDIA cards, etc. Oh well! Even a re-release is nice. :)

Sven_Q45 02-01-2008 07:14 PM


Originally Posted by s-island
It's the MIDI music from the original release played through DirectMusic's software synth.

In the DOS-Version it sounds different.

Yes, i think Sam and Max and Full Throttle were more importent, because they are older.
For my luck!
A few years ago Iīve read about a XP-Version of Full Throttle. Because FT doesnīt work on my XP. But it worked a few years ago. And suddenly, no more! :eek: I have try anything! Copy it from the CD on my PC, install it, I have lend it from somebody and so one and the same with ScummVm. Nothing!! But now at last i can play it, again. :) After 2 or 3 years without FT. :D

s-island 02-01-2008 07:48 PM


In the DOS-Version it sounds different.
It shouldn't if you run it in ScummVM and direct the MIDI to the GS software synth.

Sven_Q45 02-02-2008 06:50 AM

I have tried it.
And the music in Full Throttle was good, than?
I have only played Indy 4 in ScummVm with Windows Midi. :D

ThunderPeel2001 02-02-2008 06:56 AM

Argh. I wish someone would add 8800 support. It's incredibly annoying not being able to play it in hardware mode.

I dream of enhanced 3D models too... One day?

Sven_Q45 02-02-2008 07:07 AM

I donīt want a enhanced Sam and Max or Dott or what else. Iīm against it. This games are so good (technically).
The FM-Towns versions are an exception. :D :xp:

Tell me the system requirements of the english re-release from 2002, please.

All times are GMT -4. The time now is 03:19 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.