View Single Post
Old 11-17-2004, 02:27 PM   #11
ensiform
The Stig
 
ensiform's Avatar
 
Join Date: Nov 2004
Location: Sawtooth Cauldron
Posts: 1,241
Current Game: Borderlands 2
Here are some sound bugfixes:

when you use meditate/bow and saber is not out, usually with staff or dual sabers the saber off sound still plays fix:

meditate:

where it says

{//turn off second saber
just above the G_Sound add

if (ent->client->ps.weapon == WP_SABER)

same for {//turn off first
if (ent->client->ps.weapon == WP_SABER)

do the same with bow.

in g_cmds.c find the Cmd_SaberAttackCycle_f command

and look for the G_Sound 's in it and just add above them:
if (ent->client->ps.weapon == WP_SABER)

i suppose you could just have a return towards the top of the function like:

if (ent->client->ps.weapon == WP_SABER) {
return;
}

hope that helps


iojamp project lead / coder
ensiform is offline   you may: quote & reply,