View Single Post
Old 12-10-2008, 10:47 PM   #33
Astrotoy7
A Face from The Past
 
Astrotoy7's Avatar
 
Join Date: Apr 2002
Posts: 10,284
Notable contributor Helpful! Folder extraordinaire LFN Staff Member 
I have no experience with those specific patches, however, with anything that is executable, its best to err on the side of caution and run compat mode due to the DX9 conditions it all has to run under.

If you need a more detailed answer, the mirrored thread at the workbench is probably a better place to query monds and patches.. We are focussing on the hardware side of things on this end.

Here are those nvidia fixes: Im posting them merely as a reference to anyone who is stuck and out of ideas. I have had no need of these fixes or tweaks myself.

Here is the original thread at obsidian forums for reference

Quote:
Originally Posted by omnipace@obsidian forums
SOLUTION TO KOTOR AND KOTOR 2 RANDOM CRASHES, STARTUP CRASHES AND DRIVER STOPPED RESPONDING PROBLEM IN VISTA WITH NVIDIA DRIVERS :

This worked for me like a charm and took hours to solve the problem, but the game runs wonderful now without any crashes. (Just don't alt-tab while playing, the game doesn't like it.) Please note that I worked in a non-patched version of the game. But even with the patch there should be no random crashes except the game's original bugs.

PART 1 : INI file

Go to c:\program files\lucasarts\kotor2 and move swkotor2.ini to desktop, be sure the graphic options part is as follows :

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0

Sound options are as follows :


[Sound Options]
Number 3D Voices=16
Number 2D Voices=24
2D3D Bias=1.00
Force Software=1
EAX=0
Sound Init=0
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Disable Sound=0

After editing the file if required, remove it back to c:\program files\lucasarts\kotor2 folder.

PART II : NVIDIA Control panel

Go to your desktop right click and open NVIDIA control panel, now to the manage 3d settings and select global settings, change it as follows :

Anisotropic filtering : 16x
Anti-gamma : On
Antialias mode : App-cont
" - transparency : supersampling
Conformant text clamp : Use hardware
Err rep : Off
Ext. limit : off
Force mipmaps : Trilinear
Max. prerendered frames : 8
Multidisp/mix GPU : Single performance
Tex-filtering neg. bias : Clamp
Tex-filt. quality : High Q
Thread opt : off
Trip buffer : off
Vsync : force off

PART III : Registry setup

Click start, click start search, type regedit, run it. Search for "_swkotor.exe" (without commas). For me there were 3 entries and one of them is like :

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\{4D36E968-E421-11DE-BFC1-08002BE10318}\0000]

Under this folder, you will find _swkotor.exe entry. All entries must be REG_BINARY.

Check and add these entries :

_swkotor2.exe3D_16579523 01 00 00 00
_swkotor2.exe3D_30913648 01 00 00 00
_swkotor2.exe3D_60461791 47 67 41 08
_swkotor2.exe3D_94118636 00 00 00 00
_swkotor2.exe3DOGL_03385531 02 00 00 00
_swkotor2.exe3DOGL_12677978 60 16 62 51
_swkotor2.exe3DOGL_67207556 11 00 00 00
_swkotor2.exe3DOGL_70835937 27 00 32 22
_swkotor2.exe3DOGL_74095213 10 00 00 10
_swkotor2.exe:OGL_25631692 02 00 00 00
_swkotor2.exe:OGL_DefaultSwapInterval ff ff ff ff
_swkotor2.exe:OGL_ExtensionStringVersion 00 00 00 00
_swkotor2.exe:OGL_TexClampBehavior 00 00 00 00
_swkotor2.exe:OGL_ThreadControl 02 00 00 00
_swkotor2.exe:OGL_TripleBuffer 01 00 00 00

: D (with no gap changes to smile)

Close the registry editor, restart your computer and goodbye crashes... I believe OGL_ThreadControl is the critical point here. But to be sure I write all entries. Also changing all _swkotor2.exe entries to _swkotor.exe solves kotor 1 crashes, you may add them as seperate entries.

Also I changed my swkotor.ini file as follows :


[Graphics Options]
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0
RefreshRate=60
Width=1024
Height=768

PART IV : Bad TDR, Bad TDR...

This is an application for graphics drivers. When a driver stops responding, vista resets the device driver so the system continues stable. But the problem is old games sometimes stops responding naturally and vista thinks the game crashed. There is a fix for that problem incase your problem consists of this :

start regedit and go to [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Gr aphicsDrivers], add a new REG_DWORD entry as

TdrDdiDelay 120
TdrDelay 60

Close regedit.

PART V : RESTART YOUR COMPUTER

Somehow these changes requires restarting the computer to take effect.

PART VI : PLAY YOUR GAME AND SAVE OFTEN INCASE

Start your game in SP2 compability mode. Old mss32.dll is required also.

The game starts in windowed mode, but when you changed the resolution from the graphic options, it turns to fullscreen.

You should try turning on frame buffer effects and shadows as well from the ini file (Just set them to 1). I didn't care so I didn't try. But you may if it is important for you.

The game is also buggy and rarely crashes to desktop after these settings so save often. Good game although, or may be best...

RESULT : NVIDIA Drivers somehow sucks...

PART VII : LAST RESORT

Change your vista theme to classic to turn off windows aero subsytem. Also close the sidebar. As an option use CPU-control program and direct all processes to CPU1 incase you are using dualcore cpus.
mtfbwya


Asinus asinum fricat

Last edited by Astrotoy7; 12-11-2008 at 08:30 AM.
Astrotoy7 is offline   you may: quote & reply,