View Single Post
Old 01-06-2010, 10:09 PM   #1
ZimmMaster
Forumite
 
ZimmMaster's Avatar
 
Join Date: Jul 2008
Location: In a Video Game...
Posts: 670
Current Game: SWTOR
Helpful! Veteran Modder 
Widescreen in Patched TSL...

For those widescreen TSL users. You know that the UniWS patcher program only supports the Un-Patched TSL version. Not the updated. Well, I have figured out how to do it.

Thanks to squizzy for the resolution patcher. Which is unable to be downloaded anymore as the website went down.

You will need to download this:
Squizzy_Resolution_Patcher.7z (1.8 MB)

1. Run the swkotor2 config utility.
2. Set the value to 800x600 NOT 1024x768.
3. Hit apply then OK.
4. Unzip the file you downloaded above.
5. Now this is where you have to be careful. Make a backup of your swkotor2.exe, Mss32.dll, and swkotor2.ini.
6. Now copy all the files in the 7z file to your TSL Main Directory and run the patcher. Default path is C:\Program Files\Lucasarts\SWKotOR2
7. Once the patch is finished, open up the game, navigate to the Main Menu > Graphics Options > Screen Resolution and select your custom widescreen resolution. I can vouch for 1920x1080 resolution as I use it, but as for other widescreen resolutions, I've read that anything above 1280x720 (note the game natively supports 1280x720 by changing key values in the swkotor2.ini) works fine.

If the above is not enough, do the next step.

8.After running the patcher, go into swkotor2.ini and, under BOTH "Display Options" and "Graphics Options", change the "Width" and "Height" values to whatever you patched the resolution to ("1680" and "1050" in my case), save and exit.

Enjoy,
-ZM-

EDIT: Due to a recurring problem regarding the patch and Windows 7 PC's, I have decided to post directions on how to solve this. Please ignore the following if you do not experience this.

Certain people running windows 7 have encountered an error with their swkotor2.ini files. Basically what is happening is the permissions are not correct for the game to correctly run. Which makes the swkotor2.ini file appear really short, like this:
Quote:
[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=1920
Height=1200
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Disable Sound=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0

[Game Options]
TooltipDelay Sec=
Which in the case of this patch, would cause it to work incorrectly. Here is what needs to be done:
Navigate to your SWKotOR2 folder but don't go inside it. Right click and select properties.
Then navigate to the security tab and click the Administrators entry.
In the permissions box you should have Full Control checked. If not check it.
Now open the game and load a level. Then completely close the game. This is to put the appropriate entries into the swkotor2.ini file.
Finally open up the swkotor2.ini and navigate to the width and height values under Graphics Options and change it to the desired resolution.

If all works well, your swkotor2.ini file should be significantly longer and the problem is solved.


~ I know that you believe you understand what you think I said, but I'm not sure you realize that what you heard is not what I meant.

Last edited by ZimmMaster; 03-07-2011 at 10:57 AM.
ZimmMaster is offline   you may: quote & reply,