View Single Post
Old 04-24-2011, 04:34 PM   #6
Bullobrien
Rookie
 
Join Date: Apr 2011
Posts: 37
So I bought the Mac app store version of this and had the same question, so I thought I would see what I could find out since others might have the same questions. Through some trial and error this is what I have found so far...

The Override folder goes in application package itself. You need to right click on the application an select "Show Package Contents"
to see this file structure:

Knights of the Old republic>Content>KOTOR Data>Override

You will need to make an override folder to go here. It does not come with. Because it is in the package you will need to authenticate as an administrator to place it there.

I find that making the override folder elsewhere first then making an alias to it then moving the override folder to the right place allows me to drop stuff into the alias without constantly opening the app's package. This handy if you are going to be messing around with it some.

Here is the odd bit though. It seems as though straight up texture changes work fine in this version (PC head changes, item texture swaps, etc) but so far I have not been able to see any changes with 2da files or models. They just don't seem to have an affect. Also some model files seem to cause a crash. Not sure why. others don't.

The save games and swkotor.ini are stored in the different location:

[user]>Library>Application Support>Knights of the Old Republic>

I have successfully opened and edited save games with KSE so that part seems to work fine so far.

Things I have not tried yet...

Seeing if KOTOR tools will open anything.
Seeing if the TSLpatcher will install mods that work.

I will update this when i try those things



UPDATE:

Tried installing several PC head mods with success using the TSLpatcher. Here is how:

I moved the KOTOR Data folder from inside the Knights of the Old Republic app package. I did this so that it could be seen in the file structure of the windows emulator I am using. (for me I placed it in my documents folder since my emulator sees this as a shared drive) In my case the emulator I am using is either Virtual Box or a wine app called Winloader. Using one of these I ran the TSL exe file for the mod. When it asked me where the game directory was I browsed to the location where the KOTOR Data folder was. The TSL patcher did the rest.

Once the install was done I moved the KOTOR data folder back to its former spot inside the Knights of the Old Republic app package. I have to say I was surprised when i ran it that all the new heads from the mod showed up in character creation and no crashes. For some reason this method also made the models and 2da files work. SO my previous statement about them not working seems not to apply in this case.

So while i have not tried the specific mod mentioned above It should work using this method.

I still have not tried KOTOR tools yet. Also Have not tried any content mods. I will see about those next.

Bull

Further UPDATE

I installed several content mods. They seemed to install correctly so far.

I have used KOTOR tools now. I have not been able to see the game file structure. I think that requires a registry fix which I have not done yet. However I have been able to open 2da files and gff files that were already in my override folder and edit them successfully.

Final update.

Using the registry fix from Mithran found here:

http://www.lucasforums.com/showthread.php?t=203749

I was able to get KOTOR tool to open KOTOR and extract textures etc. This was even with the App Store version of the game. I still had to move the KOTOR Data folder out of the Application package then move it back after but it works.

Last edited by Bullobrien; 05-05-2011 at 03:44 PM.
Bullobrien is offline   you may: quote & reply,