View Single Post
Old 08-12-2012, 09:55 PM   #18
Ryuuken
Rookie
 
Join Date: Aug 2012
Posts: 12
Quote:
Originally Posted by Q View Post
The OP shouldn't have to reinstall. Looks like he/she did everything correctly. Just a couple of things need to be done and the game should run fine.

First is the Dantooine lag fix:

Second, since the OP has a multi-core CPU and is using XP, he/she is going to have set affinity to a single CPU core every time they launch the game. How I do it is to open Task Manager (right-click on the Taskbar at the bottom of Windows' desktop and select "Task Manager") and click on the "Processes" tab. Check the "Show processes for all users" box if it isn't already and then launch the game. Once you get to the game's main menu, hit the Windows key to get back to the desktop and look for the game's executable (swkotor2.exe) in the Task Manager under the "Processes" tab. When you find it, right click on it, select "set affinity" and uncheck every box but "CPU 0" and hit "OK". Once you've done that, just hit the game's icon in the Taskbar and you should be good to go. Remember to set CPU affinity like this every time you launch the game. Not doing this can cause the game to randomly crash.
I've tried this fix and even after setting CPU to using only one core and adding that command in the Swtor.ini file and loading the savegame it still freezes at about 1/3 of the way and also disabling Movies it only returns to mainscreen and crashes and I have to use Task Manager to close it
Ryuuken is offline   you may: quote & reply,