lfnetwork.com mark read register faq members calendar

Thread: Saber hilt shader problem.
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-12-2006, 10:25 AM   #1
Brood of Evil
Lurker
 
Join Date: Apr 2006
Posts: 3
Saber hilt shader problem.

I'm having a problem with a shader for my saber hilt models. I'm using an enviroment setting, however it's looking weird, as if the enviroment map is scrolling all across the model. I did an experiment, I modified the weapons.shader to add an enviroment setting to their shaders, and they look neat. It seems the problem is with my model, I've been trying to play with the UVW mapping to no avail, still looks the same. I've seen a lot of custom saber hilt models with an enviroment shader settings and they all look great, so I wonder what am I doing wrong.

This is the shader I'm using:

Code:
models\weapons2\saber_testing\saber { { map models\weapons2\saber_testing\saber blendFunc GL_ONE GL_ZERO rgbGen lightingDiffuse } { map models\weapons2\saber_testing\saber_spec blendFunc GL_SRC_ALPHA GL_ONE detail alphaGen lightingSpecular } { map gfx\effects\chr_inv blendFunc GL_DST_COLOR GL_SRC_COLOR tcGen environment } }
I know it might be hard to understand the problem without actually trying it in-game, however, I might be able to send a zip with my files, so if anyone is interested in helping I could send it, just pm with email or something. Anyway I hope someone can help, this is driving me cwazy. Thanks.
Brood of Evil is offline   you may: quote & reply,
Old 04-21-2006, 06:06 AM   #2
razorace
Impressive, Terran!
 
razorace's Avatar
 
Join Date: May 2002
Posts: 9,172
How is your shader compared to the basejka saber shaders?


---Jedi Guardian of the Newbie Questions
---Masters of the Force Team Leader / Creator
---Open Jedi Project Lead Moderator / Co-Founder
razorace is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > General Editing > Saber hilt shader problem.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:14 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.