lfnetwork.com mark read register faq members calendar

Thread: Is it a glitch or am I an idiot?
Thread Tools Display Modes
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Prev Previous Post   Next Post Next
Old 08-25-2009, 02:54 PM   #1
Singin Hobo
 
Singin Hobo's Avatar
 
Join Date: Dec 2002
Location: Texas
Posts: 2
Is it a glitch or am I an idiot?

I'm at part 3 where you have to disrupt the beams. I've beaten the room where you have to displace those boxes to fix the beam and I've done that and killed everybody. According to a walkthrough I saw the next open door should be to the left but there isn't one there or anywhere else in the room. I've gone back to the checkpoint a few times with the same result... have I hit a glitch or am I missing something? Should I restart the whole mission?


Nobody likes being beat by a hobo
Singin Hobo is offline   you may: quote & reply,
Post a new thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Fracture > Fracture General > Cybernetics Lab > Is it a glitch or am I an idiot?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:23 PM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.