lfnetwork.com mark read register faq members calendar

Thread: 64-bit update patch
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 07-16-2007, 01:33 AM   #1
Stickywulf
Rookie
 
Join Date: Jul 2007
Posts: 26
64-bit update patch

Has anyone managed to find a way to patch this game to version 1.1 on a 64bit operating system?

64 bit operating systems do not run 16bit programs. The game's header shows Grim Fandango as a 32bit program (which I can run) although the installer is only 16bit. So I can run the program but not run the installer. Bypassing the installer and copying the files from the cd onto the hard drive will allow the game to be played (in Win98 compatibility mode).

The problem is the update patch also has a 16bit installer and so cannot be installed on a 64bit operating system. I cannot find anyway to bypass the installer to get the game patched.

Has anyone managed to hack the patch's installer to find which files and settings are changed? I have searched the internet and spent days on this problem but have not yet found any solutions. If I don't find any solution then it will mean that I can never play this game again
Stickywulf is offline   you may: quote & reply,
Old 07-16-2007, 09:46 AM   #2
Du Man
Junior Member
 
Du Man's Avatar
 
Join Date: Oct 2005
Posts: 374
sorry, we don't have many people here that can answer technical computer problems. I wish there were, or at least I wish I was better at compatibility issues, but sadly i'm not.

The best thing I can do is point you to this thread where someone appeared to have had a problem like yours. The image I posted on the last post has dissappeared, but I think I can dig it up again if you need it.
Du Man is offline   you may: quote & reply,
Old 07-16-2007, 10:09 AM   #3
Thrik
Symbolically Compelling
 
Thrik's Avatar
 
Status: Administrator
Join Date: Dec 2000
Location: Nottingham, UK
Posts: 4,202
Hot Topic Starter Forum Veteran LFN Staff Member 
You could try using Benny's Grim Fandango Launcher, which acts as a patcher. I'm not sure if it actually executes the patch installation and thus fails at the same point, though.


Thrik is offline   you may: quote & reply,
Old 07-16-2007, 11:11 AM   #4
Stickywulf
Rookie
 
Join Date: Jul 2007
Posts: 26
Thanks for the replies. I installed on a friends computer with WinXP to get the registry settings but have no success patching as yet.

I can get Benny's launcher to install by adding the registry keys. I cannot yet get the patch to run in the same manner. It seems Benny's launcher is searching for different keys to which the patch is searching for. Hopefully with some persistence I can still get this working but I'm running out of ideas fast.

Unfortunately, Benny's launcher crashes at the same point during installing the patch. His site mentions creating a new installer which could be a solution for the future.

If I get it working I'll be posting the workaround here. Nice site BTW.
Stickywulf is offline   you may: quote & reply,
Old 08-02-2007, 12:07 PM   #5
Stickywulf
Rookie
 
Join Date: Jul 2007
Posts: 26
I finally got the game working in 64-bit Vista. To make it easier for the next person I have uploaded the files which I patched. Here is a step by step method to get the game to work.

1. Copy all the files from disk1 and disk2 into C:\Program Files (x86)\LucasArts\grim\. Some files are the same on both disks so just overwrite any when prompted.
2. I have uploaded some patched files. You can download the zip archive by clicking here
3. Unzip the file archive which you have downloaded and copy the files into C:\Program Files (x86)\LucasArts\grim\GRIMDATA overwriting the existing files.
4. Navigate to C:\Program Files (x86)\LucasArts\grim\GRIMDATA\GRIMFANDANGO.EXE, right click the file and choose properties. On the compatibility tab, select both "run this program as administrator" and also "run this program in compatibility mode for windows 98"
5. Right click on C:\Program Files (x86)\LucasArts\grim\GRIMDATA\GRIMFANDANGO.EXE, and choose "create shortcut". Place the shortcut on your desktop.
6. Run the game at least once by clicking on the shortcut, this will automatically create the registry entries you need.
7. [optional] To play the game without the cd's in the drive, add a new string value into the registry HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts Entertainment Company LLC\Grim Fandango\v1.0 good_times=true
8. If you have a nvidia graphic card, then you will need to disable 3d acceleration within the game's options to have clear graphics.
9. Enjoy the game.

Note: There is no need to run the update patch as this is already included in the modified files which I uploaded.

<ADDED> I just finished playing through the entire game and can confirm this game works 100% using the method I gave above.

Last edited by Stickywulf; 07-01-2008 at 03:24 PM. Reason: updated link to patch files
Stickywulf is offline   you may: quote & reply,
Old 09-27-2007, 09:58 PM   #6
diegovas
Lurker
 
Join Date: Sep 2007
Posts: 1
Did not quite work

Hello and thank you for your post.
I have Vista x64 Home Premium, I followed the instructions below, the game starts up, the screen starts flashing and keeps doing it for about 4 seconds, then I get one colored image splash and the game quits to the desktop with no errors.
Any ideas?



Quote:
Originally Posted by Stickywulf
I finally got the game working in 64-bit Vista. To make it easier for the next person I have uploaded the files which I patched. Here is a step by step method to get the game to work.

1. Copy all the files from disk1 and disk2 into C:\Program Files (x86)\LucasArts\grim\. Some files are the same on both disks so just overwrite any when prompted.
2. I have uploaded some patched files. You can download the zip archive by clicking here
3. Unzip the file archive which you have downloaded and copy the files into C:\Program Files (x86)\LucasArts\grim\GRIMDATA overwriting the existing files.
4. Navigate to C:\Program Files (x86)\LucasArts\grim\GRIMDATA\GRIMFANDANGO.EXE, right click the file and choose properties. On the compatibility tab, select both "run this program as administrator" and also "run this program in compatibility mode for windows 98"
5. Right click on C:\Program Files (x86)\LucasArts\grim\GRIMDATA\GRIMFANDANGO.EXE, and choose "create shortcut". Place the shortcut on your desktop.
6. Run the game at least once by clicking on the shortcut, this will automatically create the registry entries you need.
7. [optional] To play the game without the cd's in the drive, add a new string value into the registry HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LucasArts Entertainment Company LLC\Grim Fandango\v1.0 good_times=true
8. If you have a nvidia graphic card, then you will need to disable 3d acceleration within the game's options to have clear graphics.
9. Enjoy the game.

Note: There is no need to run the update patch as this is already included in the modified files which I uploaded.

<ADDED> I just finished playing through the entire game and can confirm this game works 100% using the method I gave above.
diegovas is offline   you may: quote & reply,
Old 10-13-2007, 04:36 PM   #7
Stickywulf
Rookie
 
Join Date: Jul 2007
Posts: 26
Quote:
Originally Posted by diegovas
Hello and thank you for your post.
I have Vista x64 Home Premium, I followed the instructions below, the game starts up, the screen starts flashing and keeps doing it for about 4 seconds, then I get one colored image splash and the game quits to the desktop with no errors.
Any ideas?
This sounds like it might be a problem with Vista's security settings. You'll need to be administrator to play the game from within the c:\program files(x86) folder. Instead of copying the game into C:\Program Files (x86)\LucasArts\grim\ copy the game into c:\users\[username]\documents\grim. This way you will have full ownership of the folder, shouldn't need to be administrator to play the game, and shouldn't get any problems with security.

I haven't tried playing the game with all the files installed into this directory, I don't know if it works or not but give it a try. If it does not work then take ownership of C:\Program Files (x86)\LucasArts\grim\. Check microsoft.com for full instructions on how to take ownership of a folder.
Stickywulf is offline   you may: quote & reply,
Old 11-05-2007, 10:39 AM   #8
bgbennyboy
Festively Plump
 
bgbennyboy's Avatar
 
Status: Super Moderator
Join Date: Feb 2002
Location: England
Posts: 1,984
LFN Staff Member 
You can also try this http://quick.mixnmojo.com/software#grimsetup

bgbennyboy is offline   you may: quote & reply,
Old 05-12-2008, 04:03 PM   #9
Lord_Draxus
Lurker
 
Join Date: May 2008
Posts: 1
Hey guys, just got the game again and need to install on Vista 64... I get a different problem though.

It's the known VOX003.LAB problem, the file just won't copy over to my hard drive... Is there any way to just get this single file?
Lord_Draxus is offline   you may: quote & reply,
Old 05-12-2008, 04:57 PM   #10
Du Man
Junior Member
 
Du Man's Avatar
 
Join Date: Oct 2005
Posts: 374
This sounds like the exact same problem this guy had

http://www.lucasforums.com/showthread.php?t=187565

However, he only got the VOX003.LAB file after someone provided it. Currently I'm not in a condition to offer it to you, but hopefully some else will. I hope Thrik posts this file on his planned update to GF.net considering how many people are starting to run the game on Vista.
Du Man is offline   you may: quote & reply,
Old 05-12-2009, 02:47 PM   #11
DivineDivine
Lurker
 
Join Date: May 2009
Posts: 3
Unhappy Hi there.

So I have a new Tosbhia Laptop Satellite series with VISTA on it.
I got Grim Fandango and figured out how to get it to run awesomely, beat the first half of the game and then:

It freezes every single time I attempt to talk to the baby winged skeletons in the birdcage at the edge of the world.... I think this has to do with VOX003 because that's the ONLY file that wouldn't load correctly.
I downloaded VOX003 from another site but now I don't know what to do with it or how to play. It still freezes.

I have run it in Windows 95 and Windows 98 modes, updated drivers etc.
I downloaded CPUKiller and ran it, to no avail
I have run it as Administrator
I have closed out every single other application that I could close out and still I cannot play past this point.

Can someone help me PLEASE? It'd driving me INSANE!
DivineDivine is offline   you may: quote & reply,
Old 05-15-2009, 10:38 PM   #12
DivineDivine
Lurker
 
Join Date: May 2009
Posts: 3
Please? Someone please check this thread *lol* I need your help so bad! I'm going nuts!
DivineDivine is offline   you may: quote & reply,
Old 05-15-2009, 11:51 PM   #13
Sabretooth
鬼龍院皐月
 
Sabretooth's Avatar
 
Join Date: Jan 2004
Location: Mumbai
Posts: 9,364
Quote:
Originally Posted by DivineDive
I downloaded VOX003 from another site but now I don't know what to do with it or how to play. It still freezes.
Haven't had the issue or anything, but it'd probably help replacing the old VOX003 with the new one you've downloaded (remember to backup the old VOX003, shouldn't be necessary, but just in case it starts an apocalypse or anything). If you don't know where the old VOX003 is, try searching with Windows or so.


Sabretooth is offline   you may: quote & reply,
Old 05-19-2009, 11:37 PM   #14
DivineDivine
Lurker
 
Join Date: May 2009
Posts: 3
Quote:
Originally Posted by Sabretooth View Post
Haven't had the issue or anything, but it'd probably help replacing the old VOX003 with the new one you've downloaded (remember to backup the old VOX003, shouldn't be necessary, but just in case it starts an apocalypse or anything). If you don't know where the old VOX003 is, try searching with Windows or so.
I know this sounds dumb but I'm not super duper computer savvy...

a little... but not super duper

How does that work? Do I just Drag & Drop the NEW file into the folder with the other file, then delete the other file? Or do I have to unzip or do something special first?

I don't understand.
DivineDivine is offline   you may: quote & reply,
Old 12-19-2010, 09:27 PM   #15
TK-949
Lurker
 
Join Date: Sep 2010
Posts: 4
Okay, I posted this 3 months ago in the Help-Forum but didn't get any response:
I tried to install Grim Fandango on my Windows 7 64bit system and tried the GrimSetup1.0.exe. But it does nothing. When I doubleclick the file a setupwindow appears in the taskbar, which I'm unable to maximize and it only can be closed through the taskmanager. Taskmanager says, that the setup is not responding. Am I doing something wrong? I have the old Windows 95/98 (German) version of Grim Fandango. The Setup doesn't work under XP either...
TK-949 is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Grim Fandango Discussion > General Forums > Glottis' Garage > 64-bit update patch

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:59 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.