lfnetwork.com mark read register faq members calendar

Thread: Fix for too fast gameplay problem!
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 02-11-2007, 08:42 PM   #1
TigerOne
Lurker
 
Join Date: Feb 2007
Posts: 2
Fix for too fast gameplay problem!

No, your eyes do not deceive you. I do believe I have a fix for the problem of way too fast gameplay. As with some NVIDIA-based problems, the answer is this: install older drivers.

I am running a Pentium M 2.0 with 2 GB RAM and an ATI Mobility Radeon X300. I had a hell of a time getting RS to run at anything approaching reasonable until I downloaded the Omega ATI Drivers v 2.6.05a, which are themselves based on the Catalyst 5.1 drivers. I installed the new drivers and voila, the game runs at a reasonable speed.

Links to the download are below: I of course cannot guarantee that this will work with your setup, but even if it does not I highly recommend playing around with the drivers available on this page--the odds are very good you'll be able to fix the problem with an older version of the drivers. If you have an NVIDIA card, you can try the NVIDIA Omegas (also linked below); I previously had an NVIDIA GeForce Go 440 card in another laptop and had good luck with Forceware 4.6.9.0. I've also linked to Laptop Video 2 Go; they are exclusively NVIDIA but have practically every NVIDIA release known to man, modded to work with any NVIDIA card.

I will note that I have occasionally run into the "ship runs off into the distance and gets real small at the center of the screen" issue with this fix, but all I have to do to take care of it is fly backwards and the camera will usually reset itself. Worst case scenario: you lose a life and the camera resets itself anyway. This is a small price to pay, I think, for being able to play the game.

Best of luck to everyone!

Links:

ATI Omega Drivers:
http://www.ngohq.com/home.php?page=F...&dwn_cat_id=14

NVIDIA Omega Drivers:
http://www.ngohq.com/home.php?page=F...&dwn_cat_id=26

LaptopVideo2Go NVIDIA Drivers:
http://www.laptopvideo2go.com/index.php?drivers
TigerOne is offline   you may: quote & reply,
Old 02-11-2007, 09:58 PM   #2
TigerOne
Lurker
 
Join Date: Feb 2007
Posts: 2
Update:

Okay, so there are apparently a few more things to keep in mind when using this fix.

1. You have to right-click on Rogue Squadron.EXE from your install folder, click Properties, then set it to Windows 95 compatibility mode AND Run in 640 x 480 resolution. You can't use Windows 98/ME compatibility, nor can you use Win 95 without checking Run in 640 x 480.

2. Apparently RS detects two video drivers now, the Primary Display Driver and a Voodoo (Glide) driver. I have had problems selecting the Voodoo driver; it has only worked for me when I either haven't selected a card (i.e., never clicked the Configuration option in the launcher) or have selected the Primary Display Driver.

3. I have figured out a nice work-around for the camera problem I mentioned above. If you hit F1 when entering a mission, it puts you into what I'm calling "cockpit mode" after one of the in-game options. Though it doesn't actually put you in the cockpit, it centers the camera on the back of your ship, so you never lose sight of it.
TigerOne is offline   you may: quote & reply,
Old 03-14-2007, 12:21 AM   #3
godiex
Lurker
 
Join Date: Mar 2007
Posts: 1
OK! OK! No more problems with this "Too fast" thing!
No "old " drivers! No "compatibility mode"!! (In fact don't use it at all and the game will
run super smoothly)

OK:
here's the solution for all of you using XP:

http://www.geocities.com/kulhain/


My Choice: CpuGrab !!

a simple slider that slows down your pc at any desire speed!

the page is full with useful little programs that do the same thing,
just slow down your machine to run those old beautiful games..
no glitches, no worries...


Please pass the info to all the other forums..! :P
godiex is offline   you may: quote & reply,
Old 09-27-2012, 12:20 PM   #4
Alvar007
Lurker
 
Join Date: Sep 2012
Posts: 8
Quote:
Originally Posted by TigerOne View Post
No, your eyes do not deceive you. I do believe I have a fix for the problem of way too fast gameplay. As with some NVIDIA-based problems, the answer is this: install older drivers.

I am running a Pentium M 2.0 with 2 GB RAM and an ATI Mobility Radeon X300. I had a hell of a time getting RS to run at anything approaching reasonable until I downloaded the Omega ATI Drivers v 2.6.05a, which are themselves based on the Catalyst 5.1 drivers. I installed the new drivers and voila, the game runs at a reasonable speed.

Links to the download are below: I of course cannot guarantee that this will work with your setup, but even if it does not I highly recommend playing around with the drivers available on this page--the odds are very good you'll be able to fix the problem with an older version of the drivers. If you have an NVIDIA card, you can try the NVIDIA Omegas (also linked below); I previously had an NVIDIA GeForce Go 440 card in another laptop and had good luck with Forceware 4.6.9.0. I've also linked to Laptop Video 2 Go; they are exclusively NVIDIA but have practically every NVIDIA release known to man, modded to work with any NVIDIA card.

I will note that I have occasionally run into the "ship runs off into the distance and gets real small at the center of the screen" issue with this fix, but all I have to do to take care of it is fly backwards and the camera will usually reset itself. Worst case scenario: you lose a life and the camera resets itself anyway. This is a small price to pay, I think, for being able to play the game.

Best of luck to everyone!

Links:

ATI Omega Drivers:
http://www.ngohq.com/home.php?page=F...&dwn_cat_id=14

NVIDIA Omega Drivers:
http://www.ngohq.com/home.php?page=F...&dwn_cat_id=26

LaptopVideo2Go NVIDIA Drivers:
http://www.laptopvideo2go.com/index.php?drivers
Are those drivers only for XP? Because I'm running windows 7 and I have the same problems
Alvar007 is offline   you may: quote & reply,
Old 02-10-2013, 04:15 PM   #5
nasetheace
Lurker
 
Join Date: Feb 2013
Posts: 1
Post FIXED!!! Turn SpeedStep back on!

In my case, I installed Rogue Squadron 3D 1.3 on an old Dell Latitude D410 laptop with onboard Intel graphics. I was tickled to death that RS did not have the crash after every mission problem on this system. However, everything was twice as fast (or more) and unplayable. After not finding much useful info online I kept poking around and noticed Windows XP (sp3) was reporting my CPU speed as 1.6 GHz AND 800 MHz on the My Computer properties page. Hmmm... if the system was reporting CPU speed wrong, that would explain a few things. lol

I went back into the BIOS and turned SpeedStep back on - I had turned it off when trying to troubleshoot overheating problems - Booted back into Windows and Voila! CPU speed shows up as 1600 MHz, AND Rogue Squadron runs FLAWLESSLY!
nasetheace is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > RogueSquadron.net > 2. Rogue Squadron > Tech Centre > Fix for too fast gameplay problem!

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:04 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.