lfnetwork.com mark read register faq members calendar

Thread: Two ways to correcting the hyper threading problem for Grim Fandango (XP user)
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-05-2005, 11:32 AM   #1
ERU
Lurker
 
ERU's Avatar
 
Join Date: Apr 2005
Posts: 1
Two ways to correct the hyper threading problem for Grim Fandango (XP user)

This has been addressed in other posts but it isn’t quite clear. There are two ways to correct the hyper threading (HT) problem with Grim Fandango:

1. While the game is running go into task manager (CTRL+ALT+DELETE) , click on “Processes” tab, right click on GRIMFANDANGO.EXE, left click on Set Affinity, uncheck CPU 1 box and then click OK. (This doesn’t work sometimes)

2. Patch the GRIMFANDANGO.EXE using imagecfg.exe. Here’s how:

a. Download imagecfg.exe at (Thanks to both sites for providing this):

http://www.reality-xp.com/support/kn...c/imagecfg.zip

or

http://www.death-web.com/files/imagecfg.zip


b. Place imagecfg.exe into same directory as GRIMFANDANGO.EXE (usually C:\Program Files\LucasArts\Grim).

c. Create a backup of the GRIMFANDANGO.EXE (copy and paste it somewhere else)

d. Open command prompt (Click on start menu, left click “run…”, type cmd)

e. Change directory to the same directory that GRIMFANDANGO.EXE and imagecfg.exe are now in, for example type: cd C:\Program Files\LucasArts\Grim

f. Type the following: imagecfg -a 0x1 GRIMFANDANGO.EXE this will patch the executable file so that it runs on one CPU.

Have fun I hope it works.

Last edited by ERU; 04-10-2005 at 03:00 PM.
ERU is offline   you may: quote & reply,
Old 04-20-2005, 03:24 PM   #2
Thrik
Symbolically Compelling
 
Thrik's Avatar
 
Status: Administrator
Join Date: Dec 2000
Location: Nottingham, UK
Posts: 4,202
Hot Topic Starter Forum Veteran LFN Staff Member 
Good thread. I'm sure this will help out those having this issue with the game a lot.


Thrik is offline   you may: quote & reply,
Old 08-27-2005, 04:25 PM   #3
melora
Lurker
 
melora's Avatar
 
Join Date: Aug 2005
Location: Pennsylvania
Posts: 2
i have tried both of the above solutions and still having the same problem as before.... manny stops dead every couple steps. it took me an hour just to walk him from his office to the garage. i also tried running in windows 98 compatiiblity mode and changing the cpu affinity thru the task manager, but still no results. does anyone have any other suggestions? i am really frustrated !
melora is offline   you may: quote & reply,
Old 03-20-2007, 01:40 PM   #4
thousandfrac
Lurker
 
thousandfrac's Avatar
 
Join Date: Mar 2007
Posts: 3
bump
this thread should be stickied


this fixed the sound cutting out completely after going to the menu problem, without having to use windows 98 compatability mode which was causing the cutscene stuttering problem for me

Last edited by thousandfrac; 03-20-2007 at 01:41 PM. Reason: addition
thousandfrac is offline   you may: quote & reply,
Old 07-17-2007, 02:44 PM   #5
Du Man
Junior Member
 
Du Man's Avatar
 
Join Date: Oct 2005
Posts: 374
wow, crap I wish I knew this earlier! stick this thread! Once I get back home (that is, in 3 weeks) I'm going to try this and see if the game works better.

edit: tried it, and works like a charm. Remeber to type "cmd" in the "run..." program under the start menu, then type in "imagecfg -a 0x1 GRIMFANDANGO.EXE" into the command prompt that should have a black background after you get to the Grim directory. Also it only worked for me when the game wasn't running.

Last edited by Du Man; 08-27-2007 at 12:43 PM.
Du Man is offline   you may: quote & reply,
Old 08-14-2007, 11:06 AM   #6
shadow_judge
Rookie
 
shadow_judge's Avatar
 
Join Date: Nov 2006
Location: Vietnam, Hanoi
Posts: 31
It ain't work with my PC, how terrible! I have to disable the HT from my Bios menu! For Manny and Meche!
shadow_judge is offline   you may: quote & reply,
Old 10-13-2007, 08:36 AM   #7
EPK
Lurker
 
Join Date: Oct 2007
Posts: 3
id like to test this out, just im having 1 problem. I am supposed to change the directory in cmd. Using the command thats given i can change to any directory in my C-drive, but not to any on E, where my game is installed ;S
EPK is offline   you may: quote & reply,
Old 10-13-2007, 08:40 AM   #8
EPK
Lurker
 
Join Date: Oct 2007
Posts: 3
aha, google is my friend =). If anyone else having same issue type this in cmd to change to other drive than your windows: CD /d E:\Grim

E beeing the directory you which to swap to, the /d i dunno what it is, but apparently its needed to change the directory.
EPK is offline   you may: quote & reply,
Old 10-13-2007, 12:56 PM   #9
UberSkull
Rookie
 
Join Date: Aug 2007
Posts: 23
If you want to change drives in Windows just type "E:"
You don't need the "cd" in front
UberSkull is offline   you may: quote & reply,
Old 10-20-2007, 03:07 AM   #10
gam4ll
Lurker
 
Join Date: Oct 2007
Posts: 1
To make it much easier, follow the thread below. It has worked for me for all of the other games as well.

Code:
http://www16.brinkster.com/salvage/thief/darkengine.htm
gam4ll is offline   you may: quote & reply,
Old 09-01-2008, 06:01 PM   #11
sebekm
Lurker
 
Join Date: Sep 2008
Posts: 2
Hyperthreading and Other Problems w/GF

A few weeks ago I tried installing and running GF on my new (one year old) system (MPC ClientPro 385 /w Intel Core2 Duo processor-2.40GHZ, 4MB cache, 1066 FSB; 4GB RAM, 160GB HDD (2x80 w/RAID controller); ATI Radeon X1650PRO 512 MB PCIE video card; Creative Soundblaster Audigy SE sound card; running Windows XP Pro w/SP3). Initially, I couldn't install the game from the CDs I purchased way back when. When that problem was solved, the game wouldn't run without freezing up after about five minutes or so (video freeze/audio stuttering). I eventually solved these problems and just finished running the game from start to finish with no problems whatsoever. Since my solutions were a combination of suggestions found by searching the internet and my own trial and error, I thought I'd post what worked for me - as it seems that lots of folks are discovering this game and trying to play it on their newer systems.
1. The solution to the install problem was to download and install the Grim Fandango replacement setup and installer program from:
http://quick.mixnmojo.com/grim-fandango-setup
Once this program was installed, I was able to install the entire game on my hard drive with no problems.
2. When I tried to run the game, I encountered the above described freezes and audio stuttering. I found that setting the game's properties in Win XP's compatibility mode to: "Windows NT 4.0 (Service Pack 5)," and then setting the game's 3d Hardware Acceleration to "OFF" through the game's Options Menu provided the best results - although the freezes/stuttering continued. (Note: I tried running the game in both Windows 95 and Windows 98/ Windows ME compatibility modes, but both of these settings produced an inferior "scratchy" audio, and degraded video.)
3. More internet searching led me to a web page titled "Game Issues with Multiproccessor/ Hyperthreading Systems" at:
http://www16.brinkster.com/salvage/thief/darkengine.htm
I followed the instructions on this page for the "permanent way" to fix the problem (the temporary fix didn't work for me). This consisted of downloading imagecfg and unzipping it to the two folders specified; creating processor.bat per the instructions; saving processor.bat to the game directory; copying a backup of grimfandango.exe to a different directory (just in case); and then modifying grimfandango.exe in the game directory with processor.bat.
Once I did this the game ran like a charm - no hangs, no problems with any of the puzzles (although the elevator puzzle and the crane/chain puzzle were a bit "twitchy" - just the same as when I ran the game on my older systems). But the graphics, sound, and everything else was spectacular. I've kept the compatibility mode set to "Windows NT 4.0 (Service Pack 5)," and the hardware acceleration set to "OFF" in the game's Options Menu.

Hope this information helps anybody having problems running the game on their XP system. Good luck!
sebekm is offline   you may: quote & reply,
Old 10-04-2008, 12:54 PM   #12
likhary
Lurker
 
Join Date: Oct 2008
Posts: 1
Remeber to type "cmd" in the "run..." program under the start menu, then type in "imagecfg -a 0x1 GRIMFANDANGO.EXE" into the command prompt that should have a black background after you get to the Grim directory

likhary is offline   you may: quote & reply,
Old 11-20-2008, 04:50 PM   #13
Amain
Lurker
 
Join Date: Nov 2008
Posts: 1
I tried the solution mentioned above (along with what seems like an extended version where I extracted imagecfg into Windows\system32 and Windows\system32\dllcache\, and while they seem to work on everyones for some reason it doesn't on mine! When I type "imagecfg -a 0x1 GRIMFANDANGO.EXE" into the cmd window I get an error saying:

'imagecfg' is not recognized as an internal or external command, operable program, or batch file

And obviously the problem remains unfixed, can anyone tell me what I'm doing wrong?
Amain is offline   you may: quote & reply,
Old 03-26-2009, 06:24 AM   #14
Voodoo_Priestess
Lurker
 
Voodoo_Priestess's Avatar
 
Join Date: Mar 2009
Location: Australia
Posts: 5
Current Game: Escape from MI
Angry Same problem

I am getting the exact same problem as the person above me.
it's irritating
Voodoo_Priestess is offline   you may: quote & reply,
Old 01-06-2010, 07:00 AM   #15
JulietteKlonk
Lurker
 
Join Date: Dec 2009
Posts: 1
thank you for the informative post and keep up the good work!
Very helpful post.


JCB
JulietteKlonk is offline   you may: quote & reply,
Old 01-23-2010, 01:33 PM   #16
MyThiKaL
Lurker
 
Join Date: Jan 2010
Posts: 1
Thanks!

Combined this with the GrimDDFix and the game runs smoothly now. Thanks for everything.
MyThiKaL is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Grim Fandango Discussion > General Forums > Glottis' Garage > Two ways to correcting the hyper threading problem for Grim Fandango (XP user)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:55 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.