lfnetwork.com mark read register faq members calendar

Thread: Stuck on Citadel Station
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 08-05-2014, 03:45 AM   #1
Mastavium
Lurker
 
Join Date: Aug 2014
Posts: 1
Stuck on Citadel Station

I've got a very irritating issue with 'TSL' going on, and I'd appreciate any help you folks could provide.

My problem lies on Citadel Station. Once I've saved the Ithorians from Czerka's assault, I make my way to Habat's shuttle, and when I attempt to board it by approaching its ramp, all seems well. I confirm that I wish to depart for Telos, and the screen darkens, as if to signal that the game's next sequence, starting with the appropriate cutscene, is going to start.

But nothing happens. The screen flashes back onto Citadel Station, exactly where I was, at the shuttle's boarding ramp. The journal is now updated and tells me I've left for Telos, but I haven't. Worse still, the shuttle's ramp doesn't activate anymore. I'm just stuck on Citadel Station.

What the hell's going on here? How do I manually initiate the Telos cutscene and game sequence/portion?
Mastavium is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > Knights of the Old Republic > Trouble Shooting > The Work Bench > Stuck on Citadel Station

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:58 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.