lfnetwork.com mark read register faq members calendar

Thread: Kiragons Theed door problem
Thread Tools Display Modes
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Old 04-20-2006, 08:40 PM   #1
kiragon
Rookie
 
Join Date: Aug 2005
Posts: 12
Arrow Kiragons Theed door problem

Hi guys,

Im having a slight problem with my doors that im making. I've made my doors which are made of 2 moving bits for the left and 2 for the right like this:


@@@@@
@@@@@
&&&&&&&&&&&&&&&&&&&

&&&&&&&&&&&&&&&&&&&
@@@@@
@@@@@

| |
| |
| |
| |
| Trigger's Here |
| |
| |
| |
| |
| |
| |

The "@" represents one part that moves to the left at a speed of 10 and "&" represents the second part that moves to the left at a speed of 30.

The right hand side is the same just rotated to move to the right. All moving parts have the value "team" and the "key 'hangerdoor1' ". The problem i am having is that that anywhere in front of the door the player activates the door and opens at an incredable speed, won't close until i move out of the doors path. The area in which the player stands to open the trigger is represented by "|"

The door does close correctly it's just the opening stage that doesn't work.

I have tryed explain this the best i can let me know if you need any more info, i was thinking that there might be a closing speed and opening speed but im not sure.


Thanks Kiragon


P.S. Here is a link to a picture of what im talking about to better describe it.

http://atomicknight.bravehost.com/untitled.JPG

You will have to copy/paste this link


Current map: Minas Tirith (RTCW)

Last edited by kiragon; 04-20-2006 at 09:09 PM.
kiragon is offline   you may: quote & reply,
Old 04-21-2006, 01:34 PM   #2
MDN14
Rookie
 
Join Date: Sep 2003
Posts: 159
To make it close even if a player is standing in the path of the door you need to check the crusher box in the doors entity window. You will have to do that for each of the 4 parts of the door.


As for the speed I am not sure what is wrong. a speed of 10 and 30 is VERY slow. I find anywhere between 70 and 100 works good in most cases for doors, so it seems strange that the doors would open so fast. Have you tried the door without the trigger? Doors do not require a trigger to target them in order to open. So if you try it without the trigger and you still get the problem then at least you know the trigger works right and it is something to do with the door entities themselves (which it most likely is anyway).

Your sure you set the key/value for the door speeds as:
Key: speed
Value: 10
?


And are you using a linear switch or not? I doubt that would really affec it in the way your describing, but who knows, it might do wierd stuff sometimes.
MDN14 is offline   you may: quote & reply,
Old 04-21-2006, 06:37 PM   #3
kiragon
Rookie
 
Join Date: Aug 2005
Posts: 12
I had already tryed the doors without a trigger as that was a backup for the doors not working in the first place. No linear switch.

I deleted all of the entities started again and it worked but i had to make the left side one team function and the right another then link the left with the right via Ctrl-K. Everything was correct it just seemed i had the problem when the left and right doors were linked by team. Unsure i will try once more and see if it works.

Another problem i add:

Key: soundset
Value: door_huge_move_lp

And when i try to load the game i get "No soundsets found for '1' " and stops trying to load the game.


K


Current map: Minas Tirith (RTCW)
kiragon is offline   you may: quote & reply,
Old 04-22-2006, 04:38 PM   #4
MDN14
Rookie
 
Join Date: Sep 2003
Posts: 159
thats because door_huge_move_lp is NOT a soundset. Try just putting "door_huge"
MDN14 is offline   you may: quote & reply,
Old 04-23-2006, 08:33 PM   #5
kiragon
Rookie
 
Join Date: Aug 2005
Posts: 12
Just tryed it and i got an error when i went to load the map
It said:

Error:
.... 1 missing sound sets!
(see above)


Current map: Minas Tirith (RTCW)
kiragon is offline   you may: quote & reply,
Old 04-24-2006, 04:11 PM   #6
{NJO}*Dark
Rookie
 
{NJO}*Dark's Avatar
 
Join Date: Feb 2004
Location: cyberspace.co.uk
Posts: 149
make sure you applied the correct sound set to all the parts of the door


~Dark
{NJO}*Dark is offline   you may: quote & reply,
Post a new thread. Add a reply to this thread. Indicate all threads in this forum as read. Subscribe to this forum. RSS feed: this forum RSS feed: all forums
Go Back   LucasForums > Network > JediKnight Series > Editing Central > JA Mapping > Kiragons Theed door problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:39 AM.

LFNetwork, LLC ©2002-2011 - All rights reserved.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.